Ethereal-dev: Re: [ethereal-dev] Patches

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Gilbert Ramirez <gram@xxxxxxxxxx>
Date: Tue, 25 Apr 2000 04:08:25 -0500
On Mon, Apr 24, 2000 at 08:30:40PM +0100, Ben Fowler wrote:
> Enclosed a small patch for packet-ip.h which is needed on my system
> to solve a problem with multiply defined ip_dissector_table; and one
> for the README.developer.
> 
> Question: Is it considered acceptable to send patches for that document, or
> is this treading the on author's toes?

Thanks. Commited. There's no problem in sending patches for that or any
document.

> ---
> 
> If I were to submit a patch that changed the name of the BASE_NONE
> enum values to
> 
> DISPLAY_BASE_NONE,
> DISPLAY_BASE_HEX
> 
> and so forth, would this be accepted. It would probably need a script
> to modify the names in all the packet-*.c files. The reason for doing
> this is to create a name space into which
> 
> DISPLAY_WIDTH_UINT8,
> DISPLAY_WIDTH_UINT16

The width is an indicator of how many bits to show, so putting "UINT"
into the name (DISPLAY_WIDTH_UINT8) is not appropriate, since the number of
bits is not linked to any field format.

But widths are not limited to multiples of 8. Take a look at the registered
fields packet-x25.c. (I assume the code is correct).

Would you want to provide macros for a set of small integers ( < 32 ) ?

DISPLAY_WIDTH_1
DISPLAY_WIDTH_2
DISPLAY_WIDTH_3
DISPLAY_WIDTH_4
...
DISPLAY_WIDTH_32

> Incidentally, when tooltips are added, I hope that the text for the 
> tooltips could
> be distinct from the blurb. I would like to write my blurb (long description
> for the man page and like documentation) in a way that may not be right
> for a tooltip.

The blurb shouldn't be too long; we're keeping all of them in memory.
Perhaps we need a way of storing additinal per-protocol and per-field documentation
that for the manpage, but is not in the program itself.

--gilbert