Ethereal-dev: [ethereal-dev] Patches

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Ben Fowler <wapdev@xxxxxxxxxxxx>
Date: Mon, 24 Apr 2000 20:30:40 +0100
Enclosed a small patch for packet-ip.h which is needed on my system
to solve a problem with multiply defined ip_dissector_table; and one
for the README.developer.

Question: Is it considered acceptable to send patches for that document, or
is this treading the on author's toes?

---

If I were to submit a patch that changed the name of the BASE_NONE
enum values to

DISPLAY_BASE_NONE,
DISPLAY_BASE_HEX

and so forth, would this be accepted. It would probably need a script
to modify the names in all the packet-*.c files. The reason for doing
this is to create a name space into which

DISPLAY_WIDTH_UINT8,
DISPLAY_WIDTH_UINT16

et cetera could also be placed, indicating that the display parameter for the
register_field_arrary operation should take from either the DISPLAY_BASE_*
values or the DISPLAY_WIDTH_* ones.

Incidentally, when tooltips are added, I hope that the text for the tooltips could
be distinct from the blurb. I would like to write my blurb (long description
for the man page and like documentation) in a way that may not be right
for a tooltip.

Ben.
Index: packet-ip.h
===================================================================
RCS file: /cvsroot/ethereal/packet-ip.h,v
retrieving revision 1.12
diff -u -r1.12 packet-ip.h
--- packet-ip.h	2000/04/20 07:05:54	1.12
+++ packet-ip.h	2000/04/24 16:56:07
@@ -84,6 +84,6 @@
     const ip_tcp_opt *, int, int, proto_tree *);
 
 /* Dissector table for "ip.proto"; used by IPv6 as well as IPv4 */
-dissector_table_t ip_dissector_table;
+extern dissector_table_t ip_dissector_table;
 
 #endif
Index: doc/README.developer
===================================================================
RCS file: /cvsroot/ethereal/doc/README.developer,v
retrieving revision 1.10
diff -u -r1.10 README.developer
--- README.developer	2000/04/06 06:38:24	1.10
+++ README.developer	2000/04/24 16:56:29
@@ -612,15 +612,16 @@
 
 bitmask
 -------
-If the field is not a bitfield, then bitmask should be set to 0.
-If it is a bitfield, then the bitmask is the mask which will
+If the field is a bitfield, then the bitmask is the mask which will
 leave only the bits needed to make the field when ANDed with a value.
 The proto_tree routines will calculate 'bitshift' automatically
-from 'bitmask', by finding the first set bit in the bitmask.
+from 'bitmask', by finding the rightmost set bit in the bitmask.
+If the field is not a bitfield, then bitmask should be set to 0.
 
 blurb
 -----
-This is a string giving a sentence or two description of the field.
+This is a string giving a proper description of the field.
+It should be at least one grammatically complete sentence.
 It is meant to provide a more detailed description of the field than the
 name alone provides. This information will be used in the man page, and
 in a future GUI display-filter creation tool. We might also add tooltips
@@ -645,7 +646,7 @@
 			0xf0, "Field A represents Apples" }},
 
 		{ &hf_field_b,
-		{ "Field B",	"proto.field_a", FT_UINT16, BASE_DEC, VALS(vs),
+		{ "Field B",	"proto.field_b", FT_UINT16, BASE_DEC, VALS(vs),
 			0x0, "Field B represents Bananas" }}
 	};
 
--
Leedsnet - The information resource for Leeds and the West Riding
< URL:http://www.leedsnet.com/mobile/ >